8/25/2026 Release
Informational
August 25
8/25/2026 Release
Status: closed
Date:
August 25
Affected Components:
API
Admin Portal
Notifications
Subscribers
Beacons
Status Page
Incident Management
Update
August 25
August 25
Fixed
- Fixed an issue where scheduled maintenance appeared in the admin services grid only on its start day instead of across its whole window.
- Fixed an issue on the Status Page history grid where scheduled maintenance without an estimated duration was not shown.
- Fixed an issue where the bulk Modify action on the Subscribers page showed "No Components", preventing components from being added to or removed from subscribers.
- Fixed an issue where the auto-close toggle was missing when editing an existing incident.
- Fixed an issue where subscriber email notifications could be switched off without the subscriber's action and without appearing in the deactivation report.
- Fixed an issue where incidents copied by an internal beacon arrived with notifications disabled even though the beacon was set to notify subscribers.
- Fixed an issue where the Get Incident API returned "not found" for draft incidents to admins, and searching by incident number failed.
- Fixed an issue where third-party status page beacons stopped detecting outages after the provider's feed address changed; the feed is now discovered automatically.
- Fixed an issue where an information post that was first drafted as an outage stayed open after publishing, and where a post drafted as information then changed to an outage closed on publish.
- Fixed an issue where posts added to a draft incident could be marked as published.
- Fixed an issue where Incident Exports returned an error, or the export email never arrived, for incidents created through the queue API.
- Fixed an issue where the fullscreen incident post editor was hidden behind the admin portal sidebar.
- Fixed an issue where incidents imported from a status page provider without a component list were silently dropped instead of being attached to the root component.
- Fixed an issue where status page beacons whose provider returned an error or redirect page showed stale component status.
- Resolved an error occurring when a cached status page entry could not be read, which caused status pages and the Incidents API to return errors, including after deployments.
- Fixed an issue on the Uptime SLA Report where an incident spanning midnight was charged to a single day instead of split across both in the page timezone.
- Fixed an issue where the Calendar Widget ignored the Week and Day display setting and always showed the month view; visitors can now switch between month, week and day.
- Fixed an issue where Calendar Widget event tooltips appeared above the calendar, or not at all, in week and day views