8/7/2026 Release

Informational
August 07

8/7/2026 Release

Status: closed
Date: August 07
Affected Components:
Notifications Beacons Incident Management
Update

August 07

August 07

Fixed
  • Fixed an issue where the same incident or scheduled maintenance could appear multiple times in incident list widgets for signed-in subscribers who belong to more than one group.
  • Fixed an issue where incidents imported from a third-party provider status page were re-saved on every poll, adding repeated "Incident Edited" timeline entries and notification emails.
  • Fixed an issue where a provider's resolution update was not applied to an incident that had already auto-closed, leaving the last visible update stuck at monitoring.
  • Fixed an issue where updates to long-running incidents imported from a provider status page could time out and fail to reach the page.
  • Fixed an issue on Beacons where a rule whose component expression matched nothing stopped the beacon from processing instead of extracting no components.
  •  Fixed an issue where notification emails sent through a custom SMTP server could be dropped when the mail server closed the connection mid-send.
Maintenance
  • Reduced repeated retries and error noise when a beacon rule builds an incident that fails validation, so a misconfigured beacon is now reported once.
  • Internal tooling and build maintenance with no change to product behavior.