7/30/2026 Release
Informational
July 30
7/30/2026 Release
Status: closed
Date:
July 30
Affected Components:
Notifications
Subscribers
Beacons
Status Page
Incident Management
Update
July 30
July 30
New
- Added the ability to map an OpenID Connect group claim to status page groups, so group membership is provisioned and removed by the identity provider at sign-in.
- Added the ability to suppress notification emails when bulk-adding subscribers.
Fixed
- Patched a vulnerability where an API integration token kept working after it was deleted; deleted tokens are now rejected immediately.
- Fixed an issue where a beacon on an internal or external status page failed with an error and created no incident whenever a ruleset was attached.
- Fixed an issue where a beacon published incidents automatically even when its integration was configured not to.
- Fixed an issue where deleted beacons continued to generate "component mapping missing" admin emails from third-party provider incidents.
- Fixed an issue where the HTML widget ignored a group applied from the page URL while other widgets honored it.
- Fixed an issue where component status widgets set to hide when empty were still shown as an empty box for subscribers whose group had no visible components.
- Fixed an issue on the History Grid where recurring future maintenance was displayed incorrectly.
- Fixed an issue where system admin notifications continued to be sent to a user after their administrator role was removed.
- Fixed an issue where administrators belonging to another company received system admin notifications without appearing in the Users list.
- Fixed an issue where the Subscriber Report grouped subscriptions by UTC date rather than the page's time zone, shifting counts by a day.
- Fixed an issue where the incident end date macros rendered empty when an incident was resolved from the incident edit screen.
- Fixed an issue where the Groups settings page was slow to load on pages with many groups.
Maintenance
- Added logging when subscribers are unsubscribed at the SMS provider.