6/29/2026 Release

Informational
June 29

6/29/2026 Release

Status: closed
Date: June 29
Affected Components:
API Subscribers Status Page Incident Management
Update

June 29

June 29

New
  • Added a keyword search to the public incident history page so visitors can find incidents by title, incident ID, or update text.
  • Added an incident duration macro for use in incident updates and notification templates.
Fixed
  • Patched a vulnerability by updating the bundled jQuery Validation library to a current release.
  • Fixed an issue where the incident history page could time out on pages holding a large number of incidents.
  • Fixed an issue where the Subscribers page intermittently failed to load its list of services.
  • Fixed an issue where incidents submitted through the API with historical timestamps failed to save their updates.
  • Fixed an issue where the incident end date macros rendered empty when an incident was resolved from the admin portal.