5/21/2026 Release

Informational
May 21

5/21/2026 Release

Status: closed
Date: May 21
Affected Components:
Admin Portal Subscribers Beacons Status Page Incident Management
Update

May 21

May 21

New
  • Added the ability to send notifications to Slack or Microsoft Teams directly from a Beacon rule.
  • Added a configurable single sign-on logout URL so users are returned to the identity provider when they sign out.
Fixed
  • Fixed an issue where the Affected Groups field on a new incident was pre-populated with every group.
  • Fixed an issue on the History Grid where an incident spanning consecutive days left one of those days blank.
  • Fixed an issue where the auto-close option was switched off when the incident start date or time was changed.
  • Fixed an issue where auto-close could not be enabled for incidents in a maintenance status.
  • Fixed an issue where the start date and estimated end date could not be amended on a draft incident.
  • Fixed an issue where the groups screen did not indicate that no components were selected.
  • Fixed an issue where subscriber invitations ignored the advanced subscriber security setting.
  • Fixed an issue where incidents on components marked "treat as cloud component" were excluded by the local and cloud incident filters.
  • Fixed an issue where the subscriber count on the Groups page did not match the Subscribers page.
  • Fixed an issue where the Users list displayed the wrong created date for an admin user.
  • Fixed an issue where the users API returned users belonging to pages no longer linked to the company.
  • Fixed an issue where Google Analytics cookies were stored on status pages that had not installed the integration.
Maintenance
  • Added operator logging for subscriber-limit failures during single sign-on, page deactivation, and provider imports.
  • Reduced log volume for image uploads and improved cached list serialization.