4/30/2026 Release
Informational
April 30
4/30/2026 Release
Status: closed
Date:
April 30
Affected Components:
Admin Portal
Notifications
Status Page
Incident Management
Update
April 30
April 30
New
- Added a warning banner to the SMS verification screen so users are told why two-factor verification is being requested before they continue.
Fixed
- Fixed an issue where an update added with the "Add Post" button on a resolved incident was published as a root cause entry instead of a normal update.
- Fixed an issue where the auto-close message was cleared from the incident form whenever an existing incident was edited.
- Fixed an issue where a group mapped to all components was not included in the affected groups of a new incident.
- Fixed an issue where the component count shown on the groups list was wrong for groups mapped to all components.
- Fixed an issue where users whose account had been changed or removed saw a 500 error instead of being signed out.
- Fixed an issue where a service component could not be deleted.
- Fixed an issue where incident notification emails rendered font colors incorrectly in classic Outlook.
Maintenance
- Reduced false-positive monitoring alerts and log noise from expected 401 and 404 responses.
- Added caching to incident search so status page and admin incident lists load faster.