3/27/2026 Release

Informational
March 27

3/27/2026 Release

Status: closed
Date: March 27
Affected Components:
API Admin Portal Notifications Beacons
Update

March 27

March 27

New
  • 1 Added a new flag to the Status Page configuration, allowing administrators to disable CAPTCHA requirements as needed.
  • 2 Introduced support for templates within Beacon messaging rules, streamlining the creation of incidents.
  • 3 SMS notifications : The system now clearly distinguishes between new incident alerts and post-incident RCA updates.
Fixed
  • 1 Resolved an error occurring when moving subscribers via the API as a standard user. The behavior now correctly aligns with admin end of the application.
  • 2 Fixed a UI issue on mobile where the "hamburger" menu icon remained visible even when no navigation items were enabled in the page design.
  • 3 Patched a vulnerability where tokens from one page were inadvertently accepted on different page domains. Cross-page token authentication is now strictly prohibited.