12/1/2025 Release

Informational
December 01

12/1/2025 Release

Status: closed
Date: December 01
Affected Components:
API Admin Portal Status Page Incident Management
Update

December 01

December 01

New
  • Added a new XSS detection mechanism that follows standard HTML sanitization protocols to enhance security.
  • Added the ability for Managers to upload images directly within the platform.
  • Introduced a new endpoint for image uploads to be used while drafting incident posts. Reference Link.
Fixed
  • Fixed an issue where modifying subscribers via CSV was failing to process.
  • Fixed an issue on the StatusCast create page by implementing new, detailed messaging for better clarity.
  • Fixed an issue where Incident Exports did not include Duration (for closed events), Affected Components, or Affected Groups.