4/18/2025 Release

Informational
April 18

4/18/2025 Release

Status: closed
Date: April 18
Affected Components:
Admin Portal Notifications Subscribers Incident Management
Update

April 18

April 18

New
  • Added support for multiple saml2 and openid connect sso providers with multiple roles
  • Added local or cloud based status filtering for html widget

Fixed
  • Fixed an issue with export all subscribers report not sending a completion notice
  • Fixed an issue with uptime report displaying incorrect downtime from browser date range filtering having a different timezone than the statuspage configured timezone
  • Fixed an issue with subscriber last login not displaying correctly for user who login with sms and have an email subscription
  • Fixed an issue with admin emails not sending incident update notifications