3/28/2025 Release

Informational
March 28

3/28/2025 Release

Status: closed
Date: March 28
Affected Components:
Integrations Incident Management
Update

March 28

March 28

New
  • Added support for multiple teams and channels for MS Teams when creating a new incident
  • Added new setting to support default sorting for incident list popups
  • Added Zenduty uptime beacon integration
Fixed
  • Fixed an issue with future scheduled maintenances and incident list popup on history grid widget
  • Fixed an issue with using auto-close message options and back-dating incidents