12/9/2024 Release

Informational
December 09

12/9/2024 Release

Status: closed
Date: December 09
Affected Components:
Groups API Admin Portal Status Page Incident Management
Update

December 09

December 09

New
  • Added external ID validation for the API incident queue.
  • Enhanced the group selector by replacing it with checkbox functionality.
Fixed
  • Resolved an issue with uptime incidents sorting incorrectly.
  • Corrected a bug where editing an informational post converted it into an RCA post type.
  • Fixed a 401 error occurring when creating a status page after reauthentication.
  • Addressed an issue where the User API returned non-assigned status page roles.
  • Ensured incident auto-close not validating estimated duration.
  • Fixed paging issues in the incident list when filtered by groups and using "load more."
  • Updated status page switching to prioritize CNAME usage when available.