9/27/2024 Release

Informational
September 27

9/27/2024 Release

Status: closed
Date: September 27
Affected Components:
API Admin Portal Notifications Services/Components Incident Management
Update

September 27

September 27

New
  • Added four (4) new API endpoints for component status history.
    • /api/v4/components/history/incident/12345
    • /api/v4/components/history/group/123
    • /api/v4/components/history?range=Last30Days
    • /api/v4/component/12345/history?range=ThisMonth
  • Added 'Export all services' functionality to the services dashboard.
Fixed
  • While creating a new incident and choosing a future or past date, the incident type will no longer automatically change.
  • Improved incident workspace for information incidents.
  • Improved page designer widget selector when scrolling.
  • Fixed issue where updating affected groups for incidents would not send notifications.
  • Fixed external status page beacons displaying duplicate services.
  • Fixed issue where some admins incorrectly received email errors indicating component mapping issues with external status page beacons.