September 17th Release

Informational
September 17

September 17th Release

Status: closed
Date: September 17
Affected Components:
Admin Portal Notifications Integrations Subscribers Beacons Services/Components Status Page Incident Management
Update

September 17

September 17

New
  • Added the ability to export incidents from the Admin UI

  • Added Reminders to the incident workspace
  • Added New Option for Service List to show non-grouped incident statuses when grouping

  • Added incident type filter for Slack incidents
  • Add option to exclude previous post updates in new Slack incident notifications

Fixed
  • Fixed scheduled maintenance {{NotifiyAtStart}} default settings being applied
  • Fixed notification reminder preview
  • Fixed issue where subscribers could not report issues
  • Fixed custom fields from displaying on status page
  • Fixed task report sorting
  • Beacons that affect components during maintenance lock will no longer notify admins