August Release

Informational
August 16

August Release

Status: closed
Date: August 16
Affected Components:
Admin Portal Integrations Subscribers Services/Components Status Page Incident Management
Update

August 16

August 16

New
  • Current Status relating to most recent incident will only show affected services of that incident instead of showing all services with an affected status
  • Added additional custom field options to show or hide during create incident
  • Added new incident post type option (Migration) 
  • Added new shortcut icon to incident lists that always opens incidents in a new tab to prevent lost search results
  • Fixed an issue with a component macros not displaying for subscribers that belong to groups and services
  • Added additional post types (Investigating,Monitoring) to brand template notifications
Fixed
  • Fixed incident start date issue cause by timezone offset when editing an existing incident
  • Fixed Uptime report page not displaying the duration in the report table
  • Fixed Uptime report displaying downtime for drafted incidents
  • Fixed subscriber selected components becoming out of sync when the subscriber exists in multiple status pages and edited from the admin editor of one status page
  • Fixed Bulk delete service components editor
  • Added improved service component search and highlight with-in admin service editor
  • Updated CSP (content-security-policy) to enforce restrictions on making external javascript requests
  • Removed legacy incident editor
  • Fixed an issue with AutoClosing informational incidents when you have treat informational posts as incidents
  • Fixed an issue with uptime api calls not honoring the uptime precision setting
  • Fixed brand templates date time macros that were not honoring subscriber timezone setting
  • Fixed webhook notifications not being sent for degraded performance status
  • Fixed sms notifications not being sent for degraded performance status 
  • Fixed incident editor displaying duplicate services
  • Fixed Calendar mini date not using account timezone offset
  • Fixed an issue where some subscribers could see indirectly affected services that they subscribed to instead of only directly affected service components
  • Fixed an issue with deleting a user in an account that belong to other account but is part of the same company
  • Added group notification dialog when modifying the groups of an incident
  • Fixed RemindAtStart not being preserved after editing an incident in draft mode
  • Added Last Login Date to subscribers export report