July Release

Informational
July 31

July Release

Status: closed
Date: July 31
Affected Components:
Admin Portal Integrations Subscribers Incident Management
Update

July 31

July 31

New
  • Added support for Incident Type option in the new incident editor
  • Added Subscriber Role in subscribers export download
  • Updated support links for statuscast
  • Added custom fields required option and editor makeover
  • Added new setting for choosing whether or not to display the created date for scheduled maintenances on status page incident details
  • Updated Slack integration for Incident Management to link to admin incident instead of the status page incident
  • Changed subscriber notification preferences to subscribe to incidents based on status instead of incident type
  • Added new third party beacon SecureAuth
  • Added additional date range filters for incident search (Next 3 Months, Next 6 Months)
  • Updated groups export to support export all and send email link to downloadable file
Fixed
  • Fixed subscriber export limiting results to 200