4/1/2024 Release

Informational
April 01

4/1/2024 Release

Status: closed
Date: April 01
Affected Components:
Groups API Admin Portal Integrations Subscribers Status Page Incident Management
Update

April 01

April 01

New
  • Added AutoAssignGroupsByComponents to Incidents Create and Update API to emulate the admin UI where groups are automatically selected based on selected components. 
  • New Incident List widget setting to sort updates of a post by the newest or oldest.

  • Added more input validation to the StatusCast login pages
  • New notification option for maintenance to send a notification when the event starts

  • New incident timeline entry for when StatusCast auto-closes an event

  • Added global support to show up to three decimal levels for uptime %

  • Added support to use the MS Teams card format for any "office.com" webhook URL 
Fixed
  • Subscriber last login timestamp shown in UTC instead of account's timezone
  • Sorting column functions on the admin subscribers page did not work correctly
  • Clicking "Load more" on the incident list widget or incident search page would skip a results page if page level grouping was enabled
  • Bulk inviting subscribers set them to the "Employee" role
  • The incident confirmation modal would show an empty list of groups on hover
  • The "subscribe" button was disabled if you were on an inner-search page