10/27/2023 Release

Informational
October 27

10/27/2023 Release

Status: closed
Date: October 27
Affected Components:
Groups API Admin Portal Integrations Subscribers Status Page Incident Management
Update

October 27

October 27

New
  • New option to force the selection of components when creating an incident

  • New option to force the selection of groups when creating an incident

  • Updated the public status page new subscription modal to require component selection

  • Added the year to the "Last Login" details for administrative user

  • Added a disable option to beacons to allow beacon processing to be turned off 

  • Added an option to Beacon extract components to allow you to stop processing if no match is found

  • New timeline entry for when NO notification channels were selected when publishing a post

  • Logic added to determine an incidents minimum role based on lowest role of selected components

  • Updated the automatic page-refresh to support 1 minute refreshes
  • Added the duration property to API results for resolved incidents
  • Added capability to search content templates when applying them in posts

  • Expanded third party cloud provider beacons to allow group assignments(manual and automated)

Fixed
  • When "Treat information posts as incidents?" is disabled editing the start date is not adjusting the auto-closure time
  • Admins created through SSO login continued to  show the "Pending" status on their user profile
  • SSO integrations allowed you to save empty configurations
  • History grid widget collapsing components when set to expand on load
  • Incidents API throwing the duplicate date/time error if the PUT endpoint included the original post