6/27/2023 Release

Informational
June 27

6/27/2023 Release

Status: closed
Date: June 27
Affected Components:
API Admin Portal Notifications Integrations Beacons Services/Components
Update

June 27

June 27

New
  • Add display for number of groups/components to incident form and workspace
  • Added new GET Component Uptime API endpoint
  • Added new Get multiple Components Uptime API endpoint
  • Added an option to allow SSO created subscriptions to be setup to get email notifications by default.
  • Added a new "Select all" option to the component selector when creating incidents and searching for components
  • Added a Default font and Font Size option to the Style and Design settings
Fixed
  • Internal status page beacon: when an incident is resolved on the main page, the incident on the internal page is not updated
  • Incident API was not returning Affected Components that had a minimum role higher than "Everyone"
  • Admin notification links were not accounting for accounts with SSO setup
  • Admin notification emails filtered out affected components with a role set higher than "Everyone"
  • Beacon escalation alerts continued to go off after a beacon has been acknowledged