3.20.2023 Release

Informational
March 20

3.20.2023 Release

Status: closed
Date: March 20
Affected Components:
Admin Portal Notifications Integrations Beacons Incident Management
Update

March 20

March 20

New
  • Ability to draft post updates and resolutions
  • Employee login route for SSO(SAML and OpenID Connect)
  • Subscribers management page enhancements
    • Improved subscriber export to include all subscription details(email, sms, webhook, preferences, and tags)
    • Added webhook support to subscriber import
    • Added a bulk modify option to allow administrators to upload a CSV of existing subscribers to add/remove groups, components, or tags
    • Added ability for administrators to unlock a subscriber when they have become locked out
    • Added component filter to table options
  • Time zone support for individual subscribers
  • Support for 2 and 3 column versions of the Components Table macro
  • Brand template macro to give you total count of affected components by group
  • Added the "Date to post" information to the summary information on the incidents search page
Fixed
  • Incidents search page slow performance
  • Schedule maintenance options not appearing right away when selecting a maintenance template
  • Saving a CNAME allowed for a trailing space
  • Administrators created through SSO appeared as "pending" in users area
  • Opening widgets in the page designer caused your screen to refocus and scroll to the top
  • From the incident workspace the link to the deliveries report is not clickable
  • Component status change popovers not including initial status
  • Email beacons showing incidents related that were not created by the beacon
  • Re-registering a SMS number from the subscription management page was not sending a confirmation SMS